aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatarLarge Libravatar /dev/urandom <johnfkennedymaili2p>2025-02-15 02:44:43 +0100
committerLibravatarLarge Libravatar /dev/urandom <johnfkennedymaili2p>2025-02-15 02:44:43 +0100
commit1a205236d019423f82d865f90ba917f24f2d2b7b (patch)
treeebc0b607d48e9144b87025bd8dfec4afd5f27da9 /Cargo.toml
parentf12e249c73f021d57d69d5f93d27e03259982edf (diff)
downloadcosin25-invite-mountainbytes-1a205236d019423f82d865f90ba917f24f2d2b7b.tar.gz
cosin25-invite-mountainbytes-1a205236d019423f82d865f90ba917f24f2d2b7b.tar.bz2
cosin25-invite-mountainbytes-1a205236d019423f82d865f90ba917f24f2d2b7b.tar.lz
cosin25-invite-mountainbytes-1a205236d019423f82d865f90ba917f24f2d2b7b.zip

feat: some feature flags

Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 9 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e52fd22..e7c8dd5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -19,6 +19,14 @@ panic = "abort"
rusttype = "0.9.3"
[features]
-default = []
+default = ["music"]
# Bundle-in SDL. Not enabled for demo submission builds. Useful for compatibility.
bundled = ["sdl2/bundled"]
+# Don't timeout the demo - pass --features notimeout to disable the DVD screen timeout
+notimeout = []
+# Make the window resizable - can let you trigger unexpected/undefined behaviour
+resizable = []
+# Use Music
+music = []
+# Compiles to <=32k on linux after UPX with --brute
+32k = []